Pylons のインストール

三宮の東遊園地の噴水

 Pylons のインストールについてのメモ。

 Pylons の公式なインストール方法というのは、easy_install を使う方法とのこと。

 Ubuntu で easy_install を利用するには、sudo apt-get install python-setuptools を実行すればいい。

 その後、sudo easy_install -U Pylons を実行する。

$ sudo easy_install -U Pylons
Searching for Pylons
Reading http://pypi.python.org/simple/Pylons/
Reading http://www.pylonshq.com/
Reading http://pylons.groovie.org/
Best match: Pylons 0.9.7rc4
Downloading http://pypi.python.org/packages/2.5/P/Pylons/Pylons-0.9.7rc4-py2.5.egg#md5=8efe329c3ef4ffd199dd630da2902f2a
Processing Pylons-0.9.7rc4-py2.5.egg
creating /usr/lib/python2.5/site-packages/Pylons-0.9.7rc4-py2.5.egg
Extracting Pylons-0.9.7rc4-py2.5.egg to /usr/lib/python2.5/site-packages
Adding Pylons 0.9.7rc4 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/Pylons-0.9.7rc4-py2.5.egg
Reading http://www.pylonshq.com/download/0.9.7
Processing dependencies for Pylons
Searching for Tempita>=0.2
Reading http://pypi.python.org/simple/Tempita/
Reading http://pythonpaste.org/tempita/
Best match: Tempita 0.3
Downloading http://pypi.python.org/packages/source/T/Tempita/Tempita-0.3.tar.gz#md5=81cbb5f38cf22f2b5c7e367986645561
Processing Tempita-0.3.tar.gz
Running Tempita-0.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-oquM-c/Tempita-0.3/egg-dist-tmp-INQwhR
Adding Tempita 0.3 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/Tempita-0.3-py2.5.egg
Searching for WebTest>=1.0.3
Reading http://pypi.python.org/simple/WebTest/
Reading http://pythonpaste.org/webtest/
Best match: WebTest 1.1
Downloading http://pylonshq.com/download/0.9.7/WebTest-1.1.tar.gz
Processing WebTest-1.1.tar.gz
Running WebTest-1.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-6uJTBt/WebTest-1.1/egg-dist-tmp-n_UqBl
Adding WebTest 1.1 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/WebTest-1.1-py2.5.egg
Searching for WebError>=0.9.1
Reading http://pypi.python.org/simple/WebError/
Best match: WebError 0.9.1
Downloading http://pypi.python.org/packages/2.5/W/WebError/WebError-0.9.1-py2.5.egg#md5=d821915037d055f4d168d2097a1c9a13
Processing WebError-0.9.1-py2.5.egg
creating /usr/lib/python2.5/site-packages/WebError-0.9.1-py2.5.egg
Extracting WebError-0.9.1-py2.5.egg to /usr/lib/python2.5/site-packages
Adding WebError 0.9.1 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/WebError-0.9.1-py2.5.egg
Searching for WebOb>=0.9.4
Reading http://pypi.python.org/simple/WebOb/
Reading http://pythonpaste.org/webob/
Best match: WebOb 0.9.4
Downloading http://pylonshq.com/download/0.9.7/WebOb-0.9.4.tar.gz
Processing WebOb-0.9.4.tar.gz
Running WebOb-0.9.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-T0_zdx/WebOb-0.9.4/egg-dist-tmp-DI-Tc7
Adding WebOb 0.9.4 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/WebOb-0.9.4-py2.5.egg
Searching for Mako>=0.2.3
Reading http://pypi.python.org/simple/Mako/
Reading http://www.makotemplates.org/
Best match: Mako 0.2.3
Downloading http://pypi.python.org/packages/source/M/Mako/Mako-0.2.3.tar.gz#md5=b847076aa1c0939382faa6a5c1f11944
Processing Mako-0.2.3.tar.gz
Running Mako-0.2.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-DeyxWR/Mako-0.2.3/egg-dist-tmp-dNgUe5
Adding Mako 0.2.3 to easy-install.pth file
Installing mako-render script to /usr/bin

Installed /usr/lib/python2.5/site-packages/Mako-0.2.3-py2.5.egg
Searching for nose>=0.10.4
Reading http://pypi.python.org/simple/nose/
Reading http://somethingaboutorange.com/mrl/projects/nose/
Best match: nose 0.10.4
Downloading http://pylonshq.com/download/0.9.7/nose-0.10.4.tar.gz
Processing nose-0.10.4.tar.gz
Running nose-0.10.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-Fbzwi-/nose-0.10.4/egg-dist-tmp-5LB5cN
zip_safe flag not set; analyzing archive contents...
nose.suite: module references __path__
nose.util: module references __file__
nose.importer: module references __file__
nose.importer: module references __path__
nose.loader: module references __path__
nose.inspector: module MAY be using inspect.findsource
nose.ext.dtcompat: module references __file__
nose.ext.dtcompat: module MAY be using inspect.getsourcefile
nose.plugins.cover: module references __file__
nose.plugins.doctests: module references __file__
Adding nose 0.10.4 to easy-install.pth file
Installing nosetests script to /usr/bin

Installed /usr/lib/python2.5/site-packages/nose-0.10.4-py2.5.egg
Searching for decorator>=2.2.0
Reading http://pypi.python.org/simple/decorator/
Reading http://www.phyast.pitt.edu/~micheles/python/documentation.html
Best match: decorator 2.3.2
Downloading http://pypi.python.org/packages/source/d/decorator/decorator-2.3.2.tar.gz#md5=c52e22e9d8f5bc0c5d70e990dbe761e0
Processing decorator-2.3.2.tar.gz
Running decorator-2.3.2/setup.py -q bdist_egg --dist-dir /tmp/easy_install-6pc2f8/decorator-2.3.2/egg-dist-tmp-LjlnwS
Adding decorator 2.3.2 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/decorator-2.3.2-py2.5.egg
Searching for simplejson>=2.0.4
Reading http://pypi.python.org/simple/simplejson/
Reading http://undefined.org/python/#simplejson
Best match: simplejson 2.0.5
Downloading http://pypi.python.org/packages/source/s/simplejson/simplejson-2.0.5.tar.gz#md5=11e65b91e7fd08eda931e683c5f98543
Processing simplejson-2.0.5.tar.gz
Running simplejson-2.0.5/setup.py -q bdist_egg --dist-dir /tmp/easy_install--TdMAT/simplejson-2.0.5/egg-dist-tmp-5BNlYa
Adding simplejson 2.0.5 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/simplejson-2.0.5-py2.5-linux-i686.egg
Searching for FormEncode>=1.2
Reading http://pypi.python.org/simple/FormEncode/
Reading http://formencode.org
Reading http://formencode.sf.net
Best match: FormEncode 1.2
Downloading http://pypi.python.org/packages/source/F/FormEncode/FormEncode-1.2.tar.gz#md5=da9d30ad0115ed8de86dc3b796899b41
Processing FormEncode-1.2.tar.gz
Running FormEncode-1.2/setup.py -q bdist_egg --dist-dir /tmp/easy_install-rGXemu/FormEncode-1.2/egg-dist-tmp-lJVAkN
warning: no files found matching '*.py' under directory '.'
warning: no files found matching '*.html' under directory 'docs'
no previously-included directories found matching '**/.svn'
zip_safe flag not set; analyzing archive contents...
formencode.api: module references __file__
formencode.util.doctest24: module references __file__
formencode.util.doctest24: module MAY be using inspect.getsourcefile
Adding FormEncode 1.2 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/FormEncode-1.2-py2.5.egg
Searching for PasteScript>=1.7.3
Reading http://pypi.python.org/simple/PasteScript/
Reading http://pythonpaste.org/script/
Best match: PasteScript 1.7.3
Downloading http://pypi.python.org/packages/source/P/PasteScript/PasteScript-1.7.3.tar.gz#md5=9101a3a23809d3413b39ba8b75dd0bce
Processing PasteScript-1.7.3.tar.gz
Running PasteScript-1.7.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-oVNG_1/PasteScript-1.7.3/egg-dist-tmp-vXnq3p
Adding PasteScript 1.7.3 to easy-install.pth file
Installing paster script to /usr/bin
Installing paster script to /usr/bin

Installed /usr/lib/python2.5/site-packages/PasteScript-1.7.3-py2.5.egg
Searching for PasteDeploy>=1.3.2
Reading http://pypi.python.org/simple/PasteDeploy/
Reading http://pythonpaste.org/deploy/
Reading http://pythonpaste.org/deploy/paste-deploy.html
Best match: PasteDeploy 1.3.2
Downloading http://pylonshq.com/download/0.9.7/PasteDeploy-1.3.2.tar.gz
Processing PasteDeploy-1.3.2.tar.gz
Running PasteDeploy-1.3.2/setup.py -q bdist_egg --dist-dir /tmp/easy_install-75F0r9/PasteDeploy-1.3.2/egg-dist-tmp-j9kGd-
warning: no files found matching 'docs/*.html'
warning: no previously-included files found matching 'docs/rebuild'
Adding PasteDeploy 1.3.2 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/PasteDeploy-1.3.2-py2.5.egg
Searching for Paste>=1.7.2
Reading http://pypi.python.org/simple/Paste/
Reading http://pythonpaste.org
Best match: Paste 1.7.2
Downloading http://pylonshq.com/download/0.9.7/Paste-1.7.2.tar.gz
Processing Paste-1.7.2.tar.gz
Running Paste-1.7.2/setup.py -q bdist_egg --dist-dir /tmp/easy_install-Z38iHS/Paste-1.7.2/egg-dist-tmp-UOrXsY
Adding Paste 1.7.2 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/Paste-1.7.2-py2.5.egg
Searching for Beaker>=1.1.2
Reading http://pypi.python.org/simple/Beaker/
Reading http://beaker.groovie.org
Best match: Beaker 1.1.2
Downloading http://pypi.python.org/packages/2.5/B/Beaker/Beaker-1.1.2-py2.5.egg#md5=09f938f89e3a96d91f4851a2f93b5027
Processing Beaker-1.1.2-py2.5.egg
creating /usr/lib/python2.5/site-packages/Beaker-1.1.2-py2.5.egg
Extracting Beaker-1.1.2-py2.5.egg to /usr/lib/python2.5/site-packages
Adding Beaker 1.1.2 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/Beaker-1.1.2-py2.5.egg
Searching for WebHelpers>=0.6.3
Reading http://pypi.python.org/simple/WebHelpers/
Reading http://pylonshq.com/WebHelpers/
Best match: WebHelpers 0.6.4
Downloading http://pypi.python.org/packages/2.5/W/WebHelpers/WebHelpers-0.6.4-py2.5.egg#md5=135c57c91309160e73317409a98dbe1c
Processing WebHelpers-0.6.4-py2.5.egg
creating /usr/lib/python2.5/site-packages/WebHelpers-0.6.4-py2.5.egg
Extracting WebHelpers-0.6.4-py2.5.egg to /usr/lib/python2.5/site-packages
Adding WebHelpers 0.6.4 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/WebHelpers-0.6.4-py2.5.egg
Searching for Routes>=1.10.1
Reading http://pypi.python.org/simple/Routes/
Reading http://routes.groovie.org/
Best match: Routes 1.10.1
Downloading http://pypi.python.org/packages/2.5/R/Routes/Routes-1.10.1-py2.5.egg#md5=70cab4f5df5c4e0008ba57e6319f7da7
Processing Routes-1.10.1-py2.5.egg
creating /usr/lib/python2.5/site-packages/Routes-1.10.1-py2.5.egg
Extracting Routes-1.10.1-py2.5.egg to /usr/lib/python2.5/site-packages
Adding Routes 1.10.1 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/Routes-1.10.1-py2.5.egg
Searching for Pygments
Reading http://pypi.python.org/simple/Pygments/
Reading http://pygments.org/
Reading http://pygments.pocoo.org/
Best match: Pygments 1.0
Downloading http://pypi.python.org/packages/2.5/P/Pygments/Pygments-1.0-py2.5.egg#md5=7e39d44a5b9ec0e037714863d5c6a2e6
Processing Pygments-1.0-py2.5.egg
creating /usr/lib/python2.5/site-packages/Pygments-1.0-py2.5.egg
Extracting Pygments-1.0-py2.5.egg to /usr/lib/python2.5/site-packages
Adding Pygments 1.0 to easy-install.pth file
Installing pygmentize script to /usr/bin

Installed /usr/lib/python2.5/site-packages/Pygments-1.0-py2.5.egg
Finished processing dependencies for Pylons

で、終わり。

コメント

このブログの人気の投稿

url に日本語が含まれている場合の Firefox と IE の挙動の違い。

2才5ヶ月の息子の絵が上手すぎる!

何故MSはOffice Document Imaging を捨てたのか、、、

インド料理の食べ方

Ubuntu で 右クリックでファイルのパスを取得したい → 難しいことは不要だった。

Nexus 9の熱暴走癖、バッテリーが少ないと発生しやすいようだ。

接点復活剤を鍵穴に一吹きすると

Xfce環境でCaps LockをCtrlに変える。

Nexus 5X が起動しなくなり、Sony Xperia XA1 Plus を買ったのだがカメラが残念すぎる。

肺活量 6500cc